Issues with Dynamic Media Purging

Incident Report for Amplience

Resolved

This incident has been resolved, and purging functionality is now operating as expected
Posted Nov 25, 2025 - 10:44 GMT

Monitoring

We are currently observing an issue with one of our upstream partners, Akamai, which is experiencing an outage.

As a result this will impact purging functionality within the Dynamic Media app. Our team is actively monitoring the situation and will provide further updates as they become available.
Posted Nov 25, 2025 - 10:09 GMT
This incident affected: Dynamic Media.