Performance problems with Dynamic Content & Virtual Staging Environments
Incident Report for Amplience
Postmortem

Issue summary

On the afternoon of Tuesday 11th January, we experienced two short outages to our Dynamic Content App.

13.32 GMT to 13.45 GMT (13 minutes)

14.59 GMT to 15.07 GMT (8 minutes)

When logging into Dynamic Content users would have experienced a white screen.

Root causes

We experienced latency on our Virtual Staging Environment which impacted our Dynamic Content App.

Corrective actions

• We pinpointed what was causing the latency and rate-limited the requests to 3 per second and scaled up our service to absorb the requests. ‌

If you would like to discuss this further, please contact your customer success manager (csteam@amplience.com)

Posted Jan 12, 2022 - 15:30 GMT

Resolved
We have monitored the platform since 15.16 GMT and believe that the incident was resolved at 15.07 GMT
Posted Jan 11, 2022 - 15:48 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 11, 2022 - 15:16 GMT
Investigating
We are currently investigating this issue.
Posted Jan 11, 2022 - 15:04 GMT
This incident affected: Dynamic Content.