No assets showing in Content Hub & Asset Library

Incident Report for Amplience

Resolved

This incident has been resolved.
Posted Sep 24, 2026 - 18:46 BST

Investigating

We’re aware of an issue where assets are not displaying in Content Hub. This also impacts users importing images into content using CMS. Our teams are actively investigating the cause.

At this time, we can confirm that already published assets are not impacted.

Further updates will follow as soon as we have more information.
Posted Sep 24, 2026 - 18:37 BST
This incident affected: Content Hub and Dynamic Content.