Delayed messages when contacting Support

Incident Report for Amplience

Resolved

The incident has been resolved.
Posted Oct 20, 2025 - 10:44 BST

Investigating

Users may be experiencing slower than normal response times when contacting support. We are working with our provider to resolve this as soon as possible.
Posted Oct 20, 2025 - 09:57 BST
This incident affected: Support.