Video Transcoding issue under investigation
Incident Report for Amplience
Postmortem

Incident Start Date: 30/10/2024, 15:10 GMT
Incident End Date: 30/10/2024, 23:30 GMT

Summary:
During this time, some users may have encountered a video processing status that appeared "In Progress" indefinitely.

Root Cause:
While videos were processed successfully, the system was unable to confirm this to end users due to an authentication error following a recent release. As a result, the processing status appeared stuck, despite completion in the backend.

Resolution:
To resolve this, we rolled back the affected release and restored full functionality.

We were able to identify all videos impacted and reprocess the correct status code (In progress to complete).

We’re also implementing additional safeguards to prevent similar issues in the future

Posted Nov 01, 2024 - 14:23 GMT

Resolved
The issue has now been resolved.
Posted Oct 31, 2024 - 00:52 GMT
Update
Video Transcoding is partially resolved. All new transcodes will process as normal. We are working on a fix for any affected videos stuck during the issue.
Posted Oct 30, 2024 - 23:11 GMT
Update
We are testing a fix that is in place, we will update shortly once we have confirmed the fix is working as expected.
Posted Oct 30, 2024 - 22:43 GMT
Identified
We have identified the issue and looking to roll back to a working version. We will update you once we have confirmed the roll back was successful.
Posted Oct 30, 2024 - 21:48 GMT
Investigating
We are currently looking into an issue with Video Transcoding. We will update shortly once we have investigated further.
Posted Oct 30, 2024 - 21:33 GMT
This incident affected: Dynamic Media.