Scheduling delays

Incident Report for Amplience

Postmortem

Issue Summary:

Between 26 and 27 June, some users experienced delays in content publishing and inconsistencies in the UI. In certain cases, content appeared to be stuck in a “Scheduling” state, even though it had successfully published on the backend.

 

Root Cause:

The incident was triggered by the localization of a large content item involving over 16,000 entries. This placed unexpected load on part of our infrastructure, leading to memory pressure and delays in processing publish events. As a result, UI updates did not accurately reflect the publishing status.

 

Resolution:

We increased system resources and redeployed affected services, which restored full functionality.

Corrective Actions: 

To help prevent similar issues in future, we have already:

  • Added new alerts to proactively monitor system load and memory usage.
  • Improved internal documentation and escalation processes. 

We are also:

  • Reviewing how large-scale content changes are processed across the platform to improve system resilience.

If you have any questions or would like to discuss this further, please contact your Customer Success Manager or email us at cs@amplience.com.

Posted Jul 03, 2025 - 09:18 BST

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 08:55 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 27, 2025 - 06:42 BST

Investigating

We are currently investigating this issue.
Posted Jun 27, 2025 - 04:28 BST
This incident affected: Dynamic Content.