Unable to log into support.amplience.com
Incident Report for Amplience
Resolved
FreshServie have resolved their Incident
Posted Jan 10, 2023 - 16:51 GMT
Investigating
The Amplience Support portal is powered by FreshService and they are currently experiencing problems. The impact to Amplience is that some users will be unable to log in. Users who are already logged in are not affected.
Posted Jan 10, 2023 - 14:52 GMT
This incident affected: Support.