Content Hub Not Displaying Assets

Incident Report for Amplience

Postmortem

Issue Content Hub Assets Not Displaying

Postmortem

Issue Summary
On Thursday, 19 February 2026, our monitoring systems detected an issue affecting the loading of assets within the platform. Shortly after, we received customer support tickets reporting problems with Content Hub and asset loading. This issue did not affect any live, published content.

Our team immediately began investigating the cause and worked to restore normal performance as quickly as possible.

Root Cause
A query that consumed a large amount of memory caused a temporary issue with asset loading in the platform. Our team has reviewed the issue and has taken steps to reduce the likelihood of similar issues in the future.

Resolution
Our engineering team quickly restarted the affected service, restoring full platform functionality.

Corrective Actions

  • We’ve reviewed our processes to strengthen system reliability and ensure faster recovery if any unexpected issues arise in the future.
Posted Feb 24, 2026 - 14:19 GMT

Resolved

We have monitored this issue and confirm we are fully operational
Posted Feb 19, 2026 - 16:07 GMT

Monitoring

We have identified the issue and Content Hub is now displaying assets, we are continuing to monitor the situation.
Posted Feb 19, 2026 - 15:19 GMT

Investigating

We are currently investigating an issue with assets not displaying on Content Hub
Posted Feb 19, 2026 - 15:01 GMT
This incident affected: Content Hub.