Unable to remove components from Dynamic Content

Incident Report for Amplience

Postmortem

Incident Start Time: 14:05 BST
Incident End Time: 16:30 BST

Issue Summary:
An incident occurred within Dynamic Content that required an immediate rollback to a previous version. The issue presented as users being unable to edit or delete content fields during content creation.

Root Cause:
The problem was introduced in the latest Content Form Extension release, which modified how form fields and remove actions were rendered and validated. When users attempted to remove a piece of content, no error appeared in the network panel; however, the browser console displayed a “not a function” error.

Corrective Actions:

  • Review and strengthen our testing processes, particularly where cross-functional teams are involved in feature releases.

  • Ensure validation coverage includes all form and field interaction scenarios before deployment.

Posted Oct 28, 2025 - 17:02 GMT

Resolved

We can confirm that the affected feature has been rolled back and functionality has returned to normal.
Posted Oct 22, 2025 - 16:09 BST

Identified

We’ve identified an issue with a recent release that’s impacting content creation. Our team is currently rolling back the affected feature, and we’ll confirm once the rollback is complete
Posted Oct 22, 2025 - 16:06 BST
This incident affected: Dynamic Content.