Issue with switching repositories

Incident Report for Amplience

Postmortem

Incident Start Time: Friday, 8th May, 09.57 BST
Incident End Time: Monday, 12th May, 14.18 BST

Issue Summary:
An incident occurred within Dynamic Content that required an immediate rollback to a previous version. Users were unable to navigate through different Repositories. 

Root Cause:
The issue was introduced in the latest Content Management App release, which included a new multi-select feature for the repository library. The feature caused unintended behaviour that impacted repository navigation functionality.

Corrective Actions:

  • Review release verification procedures to improve early detection of UI interaction issues.
Posted May 18, 2026 - 10:15 BST

Resolved

This incident has been resolved.
Posted May 11, 2026 - 16:24 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 11, 2026 - 14:17 BST

Identified

Users may experience an issue when switching repositories, where the selected repository updates but the displayed content does not reflect the newly selected repository.
Posted May 11, 2026 - 13:53 BST
This incident affected: Dynamic Content.