Intermittent Stuck Scheduling and Publishing in Dynamic Content
Incident Report for Amplience
Postmortem

Issue Summary

On the afternoon of Monday 1st May, we identified 3 issues within Dynamic Content whereby users were unable to see content items publish, receive webhooks and Schedule editions.

Root Causes

Our Operations team discovered a faulty shard after extensive testing was conducted in our QA environment. The faulty shard was replaced and we have monitored a healthy environment since this change.

Corrective Actions

Internally, we have discussed this at length to ensure integrity of service. Further monitoring is to be implemented to catch the errors earlier in our incident pipeline. We have also reviewed our processes to ensure a more efficient recovery of service.

‌If you would like to discuss this further, please contact your customer success manager (csteam@amplience.com)

Posted May 03, 2023 - 16:52 BST

Resolved
The incident has been resolved and a post mortem report will be released outlining the issue and resolution.
Posted May 01, 2023 - 21:45 BST
Identified
The issue has been identified and a fix is being implemented.
Posted May 01, 2023 - 21:25 BST
Investigating
We are currently investigating this issue.
Posted May 01, 2023 - 19:43 BST
This incident affected: Dynamic Content.