Media Delivery (assets) disruption

Incident Report for Amplience

Postmortem

Incident Start Time: 21:22 BST 

Incident End Time: 21:39 BST

 

 Issue Summary:

On 19th September, we experienced a disruption to our media delivery service. Impacted customers saw images failing to load.

Root Cause:

Amplience operates a multi-layer CDN infrastructure to ensure continuous delivery. A change related to Cloudflare affected approximately 0.04% of our daily requests. 

Our automatic failover logic initiated during this incident, diverting traffic away from Cloudflare to Akamai.

Corrective Actions:

  • While the overall percentage of requests impacted was low, the experience for affected customers was significant. We are fine-tuning our process to make the failover more efficient. 
  • We are awaiting a full root cause analysis (RCA) from our provider, Cloudflare.

If you have any questions or would like to discuss this further, please reach out to your Customer Success Manager or contact us at csteam@amplience.com.

Posted Sep 22, 2025 - 16:55 BST

Resolved

The incident has been resolved
Posted Sep 19, 2025 - 22:54 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 19, 2025 - 21:51 BST

Identified

We are experiencing an outage with our Media Delivery (assets) service, which impacts published assets. We have identified the fault and now investigating the fix
Posted Sep 19, 2025 - 21:42 BST
This incident affected: Content Hub and Dynamic Media.